Прикладной пример переработки стандартной формы РМК - Розница

Программирование - Работа с интерфейсом

РМК доработка РМК Розница

66
Простой пример, как с помощью программного изменения шрифтов элементов формы достичь наилучшего результата отображения на примере формы РМК.

Итак по порядку. 

Начнем со стандартной формы РМК Розницы (ею, кстати и закончим).

Давно не давала покоя ее "недоделанность". Очень сложно показать кассиру, работающему исключительно в обработке РМК плюсы их новой программы. "Их нет!" скажет любой кассир, работавший до этого в конкурентных продуктах и будет по-своему прав. Не понимаю, почему удобство РМК в создании Розницы стоит на последнем месте.

Последней каплей моего терпения стала установки и запуск Розницы в небольшом кафе, владелец которого наш хороший, благодарный клиент, с которым мы сотрудничаем на протяжении многих лет. 

Почему Розница? Не потянут они общепит. Обороты не те, персонал не обучен, да и ни к чему. А Розница справится со всеми требованиями клиента. 

В общем дошли до РМК. Заполнили меню, настроили оборудование, УТМы, поставили тач, и получили вот это:

Просто при вызове "Быстрых товаров", если в Палитре есть группы (2 уровня), то вместо открытия панели на форме РМК открывается блокирующая форма подбора справочника "Палитра быстрых товаров". 

Теперь, если наш покупатель гурман и не ограничивается тарелкой борща или комплексным, то по окончании ввода блюд кассир вынужден "возить!" пальцем палитру по тачу, распихивая ее в разные углы и укромные места, роняя при этом реплики и разнообразные салаты в подобранный чек, чтобы посмотреть, все-ли по заказу выбрано верно. Здесь я тихонько удалился, ссылаясь на "надо посмотреть" и "вроде температура опять поднялась".

Стоит также заметить, что кнопки реализованы как "Поле картинки", вероятно с далеко идущими планами, однако планы еще далеки, а нажатие на поле-картинку не визуально. То есть если нажать на обычную кнопку, она проваливается и пользователь видит, что он нажал на кнопку. Нажатие на картинку ничем не сопровождается. Ни визуальным эффектом, ни звуком, ни каким-либо намеком, кроме выполняемого кнопкой действия. А если компьютер не быстрый или нажатие на кнопку требует продолжительных расчетов, то пользователь нажимает на нее многократно. Последствия можно только предполагать.

Ну, хватит лирики. Поговорим о шрифтах. Но сначала добавим форме, словами 1С, юзабилити. ))) Короче, сделаем ее удобнее.

1. Мне не понравилось расположение элементов. Верхние кнопки основных команд с одновременно открытой панелью дополнительных команд внизу  съедают не менее 50% высоты таблицы чека при разрешении 1024х768. Про 800х600 мы даже не говорим, хотя многие профессиональные мониторы кассира имеют разрешение именно 800х600.

Отметим, что чаще стали использоваться мониторы с соотношением сторон не 4:3, а 16:9. Т.е. Таблица с товарами сокращается до 4-6 строк. 

Вывод. Перенести кнопки основных действий на правую или левую часть экрана и расположить их вертикально. Я расположил справа. Для праворуких. Информационные группы пока уберем. Они съели до 20% места на форме. Вернем потом на место, разобравшись к чему расточительство.

Вот что из этого получилось (разрешение 1680х1050):

2. Места стало в 2 раза больше, но с быстрыми товарами мы еще не разобрались. Окно с кнопками все еще вываливается поверх основной формы.

Надо, чтобы окно открывалось сбоку. Поискал в коде заполнение кнопок быстрых товаров. Действительно. При инициализации РМК заполняется только верхняя группа быстрых товаров. Все что ниже первого уровня не хранится в форме, а добавляется из открываемой формы подбора справочника - "Палитры быстрых товаров". 

Зачем переделывать то, что уже работает? Точно, незачем. Пусть форма подбора приклеивается слева от основной формы.

Отдельное спасибо за идею Павлу Одинцову (Darklight) и Дмитрию Васильеву(dandykry).

Дмитрий предложил приклеить окно сбоку: http://v8.1c.ru/o7/201502wnds/index.htm

А Павлом был предложен вариант использовать WScript.Shell для закрепления открытого окна программно. 

&НаКлиенте
Процедура ЗакрепитьСправа() экспорт
    Если ЭтаФорма.ВводДоступен() Тогда
        WSHShell = Новый COMОбъект("WScript.Shell");
        WSHShell.SendKeys("%");
        WSHShell.SendKeys("{DOWN 5}");
        WSHShell.SendKeys("{RIGHT}");
        WSHShell.SendKeys("{UP 5}");
        WSHShell.SendKeys("{ENTER}");
    КонецЕсли;
КонецПроцедуры

и 

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ПодключитьОбработчикОжидания("ЗакрепитьСправа",0.1,Истина);
КонецПроцедуры

Смысл функции ЗакрепитьСправа() Нажать на последовательность кнопок: Alt, вниз 5 раз, вправо, вверх 5 раз, Enter. Что равносильно: Главное меню - Окна - Закрепить справа. (если слева, то Up 6)

Обработчик ожидания нужен для выполнения "скрипта" над уже открытим окном. Прямой вызов ЗакрепитьСправа()  из той же функции, которая открывает форму подбора недопустим.   

В результате получилось так:

3. Ну, раз пошла такая пляска, то кнопкам тоже достанется.

Меняем картинки на кнопки. Чуть форматируем информационные надписи и результат воодушевляет на дальнейшие подвиги.

Еще немного форматирования. Панель быстрых товаров отлично прижилась справа. Форма не расползается.

Разочарование ждало на этапе полевых испытаний.

Форма расползлась на разрешении монитора 1024х768.

4. Нормальный человек так бы и сказал: Надо масштабировать. Масштаб - это наше все! 

Как? Выход нашелся, как всегда, простой. Будем масштабировать шрифты. 

На этапе инициализации РМК собираем наименования всех элементов формы, имеющих свойство "Шрифт". И в отдельный массив элементы таблицы товаров (как показала практика очень удобно масштабировать независимо все элементы формы и отдельно таблицу товаров).

	МассивИменТаблицы = Новый Массив;
 	МассивИмен = Новый Массив;
	Для Каждого ЭлемФормы Из Элементы цикл //Перебор всех элементов формы
		Попытка 
			Шрифт = ЭлемФормы.Шрифт;
			МассивИмен.Добавить(ЭлемФормы.Имя);
		Исключение	КонецПопытки; //У групп, к примеру, нет свойства шрифт. Сработает исключение.
	КонецЦикла;	
	Для каждого Элемент Из Элементы.Товары.ПодчиненныеЭлементы Цикл //Здесь сложнее, нам нужны только подчиненные
		Если НЕ Элемент.Вид = ВидГруппыФормы.ГруппаКолонок Тогда
			МассивИменТаблицы.Добавить(Элемент.Имя);
			
		Иначе //Группа
			Для каждого ЭлементГруппы1 Из Элемент.ПодчиненныеЭлементы Цикл
				Если НЕ ЭлементГруппы1.Вид = ВидГруппыФормы.ГруппаКолонок Тогда
					МассивИменТаблицы.Добавить(ЭлементГруппы1.Имя);
				Иначе //Группа
					Для каждого ЭлементГруппы2 Из ЭлементГруппы1.ПодчиненныеЭлементы Цикл
						Если НЕ ЭлементГруппы2.Вид = ВидГруппыФормы.ГруппаКолонок Тогда
							МассивИменТаблицы.Добавить(ЭлементГруппы2.Имя);
						КонецЕсли;	
					КонецЦикла;		
			   КонецЕсли;
			КонецЦикла; 
		КонецЕсли; 
	КонецЦикла; 

Да... Не рекурсия... Но, если вызвать на клиенте функцию с передачей ей в параметре тип Элемент формы, то получим "Отсутствует отображение для типа таблицаформы...". Не стал задумываться, пока, как сделать красивее. Клиент ждет результата. 

Расположил, временно, чтобы поиграться, кнопки управления масштабом на форме. Кнопку "Изменить форму" тоже вывел. Почему кассира обделили - не понимаю. Потом спрячем их с глаз долой, чтобы не занимали драгоценное пространство, в меню настроек формы.

Команды кнопок вызывают процедуры, в которых происходит изменение шрифта всех элементов формы или элементов таблицы товаров. Получилось так. При изменении масштаба шрифта заголовка кнопки, сама кнопка увеличивается или уменьшается, если не задан жесткий размер. Это нам и нужно.

(следует заметить, что изменение размера шрифта приводит к противоречивым результатам. Сильно зависит от установленных флагов стилей. Если установлено в Авто, то размер не меняется, поэтому используем масштаб шрифта. Он работает идеально.)

Новый Шрифт(<ИмяШрифта>, <Размер>, <Жирный>, <Наклонный>, <Подчеркнутый>, <Зачеркнутый>, <Масштаб>) 

<Масштаб> (необязательный)

Тип: Число.
Задает значение свойства Масштаб.
Значение по умолчанию: 100.

Вот пример кода уменьшения масштаба шрифта таблицы товаров на 10% и увеличения масштаба шрифтов всех элементов формы на 10%:

&НаКлиенте
Процедура УменьшитьШрифт(Команда)
	Для каждого ЭлементМассива Из МассивИменТаблицы Цикл
	   	Масштаб = 90;
		Элементы[ЭлементМассива].Шрифт = Новый Шрифт(Элементы[ЭлементМассива].Шрифт, ,,,,,,Масштаб);
	КонецЦикла; 
КонецПроцедуры

&НаКлиенте
Процедура УвеличитьМасштаб(Команда)
	Для каждого ЭлементМассива Из МассивИмен Цикл
	   	Масштаб = 110;
		Элементы[ЭлементМассива].Шрифт = Новый Шрифт(Элементы[ЭлементМассива].Шрифт, ,,,,,,Масштаб);
	КонецЦикла; 
КонецПроцедуры

Изначально был такой вариант, но он не работал:

		Масштаб = Элементы[ЭлементМассива].Шрифт.Масштаб;
		Шаг = 20; //20%
		Масштаб = Масштаб + Шаг;
		Элементы[ЭлементМассива].Шрифт = Новый Шрифт(Элементы[ЭлементМассива].Шрифт, ,,,,,,Масштаб);

Этот вариант, почему-то постоянно уменьшал, значительно более, чем на 20%, хотя должен был наоборот, увеличивать на 20%.

Сравним оба варианта увеличения шрифта:

Правильный:

	   	Масштаб = 110;
		Элементы[ЭлементМассива].Шрифт = Новый Шрифт(Элементы[ЭлементМассива].Шрифт, ,,,,,,Масштаб);

 Неправильный:

		Масштаб = Масштаб + Шаг;//Масштаб - Шаг;
		Элементы[ЭлементМассива].Шрифт = Новый Шрифт(Элементы[ЭлементМассива].Шрифт, ,,,,,,Масштаб);

Просто после присвоения элементу шрифта с новым масштабом, Элемент так и запомнит шрифт с новым масштабом. И это не обязательно 100%.

Новый масштаб будет задан не от эталонного (100%) а от текущего значения масштаба шрифта.

Итак, если последнее значение масштаба шрифта 70%, а мы хотим увеличить на 10%, то получится, что Масштаб = 80.

После присвоения нового шрифта его масштаб составит 80% от предыдущих 70% (а не от эталонного 100%), т.е. шрифт уменьшится, а не увеличится.

Каждый раз, когда мы хотим увеличить шрифт мы должны указать ему не на сколько процентов увеличить, а сколько процентов он будет составлять от текущего масштаба. 

т.е. если мы хотим увеличить на 20%, то надо просто указать масштаб = 120, а если уменьшить на 20%, то, соответственно Масштаб = 80.

После того, как я усвоил эту простую истину форма снова ожила уже на любых разрешениях. Надо только менять масштаб на 20-30%:

800х600

1024х768

1680х1050 (шрифт таблицы мелковат):

1680х1050 (вот где пригодилось отдельное масштабирование шрифтов таблицы товаров):

В заключение расскажу, что планирую доделать в интерфейсе кассира, чтобы показать Розницу "Лицом" а не как в штатном РМК.

1. При открытии форма сама выберет какой масштаб шрифтов ей выбрать. И впишется в любое разрешение монитора, не съедая слова в кнопках.

2. Надо добавить сохранение текущей настройки масштаба, чтобы каждый раз не пересчитывать при открытии.

Стандартных способов получить разрешение или размер формы нет. Добавил возможность сохранять масштаб основных элементов формы. 

3. Надо бы разрешить пользователю компоновать форму так, как ему будет удобнее в ней работать. И сохранять настройки под каждого пользователя.

4. Переработать палитры быстрых товаров. То что есть - не красиво и не функционально. Быстрые товары должны жить на той же форме РМК. Использование скриптов хоть и помогло, но не является самым красивым решением.

Готово. Пришлось повозиться с алгоритмом построения. 

5. Добавить форму ввода количества товаров. Когда продается дробное количество с тача затруднительно вводить число, используя встроенный "калькулятор"

Готово. Количество вводится с доп. формы клавиатуры. Добавил, кстати, кнопку "Сторно", которую тщетно ищут новообращенные в 1С Розницу. По той же причине назвал кнопку количество "Х". 

Делюсь результатом.

Разрешение 1024х768. Открыто нижнее меню доп. операций и меню настроек масштаба элементов.

Разрешение 1680 х1050. Добавлена кнопка ввода количества. Кнопка "сторно" доступна только если кассиру разрешено удалять строки.

РМК может работать как дополнительная подключаемая обработка, что позволит ее использование с базовыми версиями продукта:

Для запуска потребуется создать ярлык и прописать в нем команду запуска обработки из внешнего файла (пример командной строки):

"C:\Program Files (x86)\1cv8\common\1cestart.exe" ENTERPRISE /F "E:\Разработки\Розница" /N"Кассир" /P"парольКассира" /Execute"E:\Разработки\РМК\РМК_Внешняя.epf"

Надеюсь, что мой опыт кому-нибудь пригодится.

С удовольствием приму любые идеи направленные на улучшение РМК. Буду рад их с Вами обсудить.

66

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Saipl 6 05.10.18 05:18 Сейчас в теме
Поддерживаю всегда раздражала "убогость" интерфейса кассира.
В данный момент занимаюсь внедрением конфигурации Розница "Магазин одежды и обуви" Рарус - они решили эту проблему кардинально - сделали отдельный РМК на обычных формах.
2. obmanOZ 2 05.10.18 08:51 Сейчас в теме
(1) А в типовых розницах последних релизах убрали РМК на неуправляемой форме? В ред. 2.0 была
6. asdfgcom 230 05.10.18 12:11 Сейчас в теме
(2) В стандартной Рознице 2.2 РМК только на управляемых формах
5. asdfgcom 230 05.10.18 10:59 Сейчас в теме
(1) Да-да... Управляемые формы они же такие неуправляемые! ©
Однако, управляемость форм позволила масштабировать под любые мониторы. Этим опытом и хотел со всеми поделиться.
7. RocKeR_13 484 05.10.18 13:10 Сейчас в теме
(5) у вас режим открытия окна РМК какой? Я так понимаю, независимый вместо блокировки всего интерфейса? Ибо не хочет никак прикреплять)
8. asdfgcom 230 05.10.18 13:23 Сейчас в теме
(7) Да, снята блокировка интерфейса и при открытии формы "Форма" из формы "ФормаМеню" и при открытии быстрых товаров.
Кроме того, для использования Альтернативного РМК в составе с базовыми продуктами требуется возможность включать ее в состав дополнительных обработок. При этом, чтобы не наступать на мои грабли требуется изменить наименование формы "Форма" в "ФормаРМК", например. Имя формы "ФормаМеню" переименовать в "Форма". Т.к. стандартный вызов подключенной обработки пытался открыть именно форму с именем "Форма", которая не является основной.
3. baracuda 3 05.10.18 09:36 Сейчас в теме
Очень круто сделано, надеюсь и я скоро возьмусь за интерфейс РМК
4. RocKeR_13 484 05.10.18 10:02 Сейчас в теме
Делаю кнопочный подбор (https://infostart.ru/public/908730/), как раз сейчас тоже работаю над масштабом. За наводку на прикрепление окон спасибо! Жаль, что программно штатными средствами не прикрепить, но с другой стороны мало кто на Linux'е в Рознице работает)
9. Dream_kz 78 05.10.18 14:26 Сейчас в теме
Мне нравится. Тоже когда увидел РМК в рознице 2.2 ужаснулся, какое оно кривое.
Теперь осталось выложить это расширением, чтоб установил, и сразу красиво)
10. asdfgcom 230 05.10.18 14:45 Сейчас в теме
(9) Сделаем расширение. И даже сделаем как подключаемую обработку для базовых версий.
11. Дмитрий74Чел 18 05.10.18 17:39 Сейчас в теме
asdfgcom,
Решал аналогичную проблему на ОФ на самописном интерфейсе ТСД. Однажды произошло слияние c другой компанией, а у них было 2 типоразмера ТСД, причем оба не совпадали с нашим. Они-то себе ранее 2 формы нарисовали под разные разрешения, но меня такой вариант не устраивал. Сделал масштабирование шрифта аналогично описанному в статье.
Вот только использовал не шаг увеличения шрифта, а коэффициент, который рассчитывал не от текущего размера шрифта, а от ширины формы (ШиринаТекущая/ШиринаПриРазработке). Попробуйте отталкиваться от ширины формы - вдруг получше масштаб сыграет.
asdfgcom; +1 Ответить
12. asdfgcom 230 05.10.18 17:56 Сейчас в теме
(11) Ширина формы - Отлично! Ведь разрешение мы не можем получить. Тем более, если РМК стартует в окне. Спасибо за совет.
13. triviumfan 05.10.18 22:50 Сейчас в теме
Есть же справочник "НастройкиРМК", можно гибко настроить панели, кнопки и много всего.
Масштабирование давно в такси появилось.
Нормальная форма, да ещё и очень гибкая.
В таких случаях говорят "всем не угодишь" (с)
15. asdfgcom 230 05.10.18 23:47 Сейчас в теме
(13) Настройки РМК не позволяют делать практически ничего. Тоже так думал, пока не сравнил РМК Розницы с РМК других разработчиков. Я постарался достаточно подробно изложить в статье, что меня сподвигло на многодневную доводку РМК. Видимо Вы не внимательно прочли статью или не имели богатой практики внедрений этого продукта в разных сферах торговли. Попробуйте поиграть разрешениями своего монитора снижая вплоть до 800 х 600 с запущенной РМК. Теперь попробуйте вызвать палитру быстрых товаров с более, чем 1 уровнем товаров (страница, в ней товары). Теперь попробуйте прочитать, не закрывая палитру, что уже набрано в чек. Поставьте себя на место кассира, который работает с этим 8 часовую смену с монитором диагональю 10" и разрешением 800х600 (один из самых популярных стандартов профессиональных POS мониторов до недавнего времени)
Для сравнения кассир с РМК Штрих-Кассир (Конкурентный продукт) видит на вышеуказанном мониторе около 20 строк с товаром, может и более. Сомневаюсь, если наш РМК выдаст хотя бы 5 с открытым нижним меню.
И напоследок. Сравните, какой РМК Вы выберете, если у Вас будет выбор
Прикрепленные файлы:
18. triviumfan 06.10.18 22:18 Сейчас в теме
(15) Наверное, первый, он покрупнее, а ещё в типовом варианте можно на каждый товар/категорию иконку задать.
В статье я увидел лишь хейт и то, что так для вас удобнее. Кнопки вместо картинок, цвет, панель... Но это все относительно.
Вертикальная прокрутка в быстром подборе товара ... - в чем удивление то? расширить и все. Кто ж виноват, что у вас там столько всего...
Вы предлагаете прятающуюся панель... да, с какой-то стороны это красиво, элегантно, удобно, для кого-то!
Завтра вы захотите 50 товаров там располагать... там итак все мелко.
Вообще у меня под рукой рарусовская РМК, но как я понял, то она почти такая же как от 1с, но немного допиленная.

ЗЫ: я бы лишь форму подбора товара подправил. Наверное, категории расположил вертикально слева, а товары горизонтально справа.
. Сомневаюсь, если наш РМК выдаст хотя бы 5 с открытым нижним меню

Нажми f10 - свернется панель.
Если у вас средний чек из большого количества позиций, и кассир хочет видеть как можно больше пробиваемых товаров в таблице... опять же - все относительно. Если это ларёк и средний чек из 2-5 позиций, то накой им ваша таблица из 20 товаров?:) Лишнее место!
19. asdfgcom 230 06.10.18 23:09 Сейчас в теме
(18) Для кафе ставлю сейчас. То что есть - не удобно. Сделал удобно. Сейчас дописал вскрытие тары ЕГАИС. Будет вызываться кнопкой из доп. меню снизу.
Просто мы по разному смотрим на вещи. Вы используете то, что есть. А я хочу сделать лучше.
Побаиваюсь, кстати, ставить розницу в продуктовый магазин с высокой проходимостью. После Штрих-Кассир продавцы взвоют. Потребуют вернуть как было. То, что написано 1С им покажется непонятным неудобным и медленным (не понаслышке. Уже проходили не один раз. Хорошо, магазины маленькие, с низкой проходимостью, 1-2 кассы). Как вариант ставить фронтовые решения конкурентов и настраивать обмен с розницей. И вот же опять! Зачем? Зачем, если можно сделать также или лучше, чем у них!.. Что и пытаюсь сделать.
14. asdfgcom 230 05.10.18 23:28 Сейчас в теме
Переработал открытие быстрых товаров. Быстрые товары теперь "выдвигаются" Справа при нажатии на кнопку быстрых товаров. Без открытия и приклеивания формы справочника. Создание кнопок скопипастил с формы справочника быстрых товаров.
Прикрепленные файлы:
16. CheBurator 3567 06.10.18 18:27 Сейчас в теме
Огромное неиспользуемое место, там где на картинках пишется "Пирамида..."
сумы разместить не в строку,а в столбик - легче соотносить, справа/слева от этого "столбика" - вывод "пирамида"...
17. asdfgcom 230 06.10.18 19:00 Сейчас в теме
(16) Исправил, сняв видимость с элемента "СтраницаЧеков". На картинках эта страница не задействована. В ней табличная часть. Как ни крути она съедает место и в результате получаем пустоту. Разбираюсь сейчас с управлением видимостью этой страницы. Пусть появляется, когда в ней будет необходимость. Кроме того сменил поля Сумма, Всего, Скидка на декорации. Они меняют размер в зависимости от длины форматированной строки суммы и не пожирают все пространство как поля. Теперь выглядит так. Прикрепил картинку. Менее информативно, но это не на долго.
Прикрепленные файлы:
20. asdfgcom 230 10.10.18 17:01 Сейчас в теме
Ура! Первое испытание прошло на таче 1027х768. Жду отзывов и пожеланий от Заказчика. Есть корявки со вскрытием тары ЕГАИС. Пришлось сканировать акцизу 2 раза в чеке и во вскрытии. Но это легко поправимо.
21. more 10.10.18 21:55 Сейчас в теме
Согласен с автором. 1С делает крайне не удобный РМК. Мне кажется, что они ни разу не занимались внедрением розницы в боевых условиях. У меня каждый магазин - это обсуждение с заказчиком. Заказчик ни как не хочет платить за доработку интерфейса, а работы РМК хотят как у взрослых сетей. Только самые маленькие магазины согласны мириться с РМК от 1С.
ИНТЕРЕСНЫЕ решения.
asdfgcom; +1 Ответить
22. sayae 13 09.11.18 15:12 Сейчас в теме
Автоматизируем магазины разливного пива - LidosPOS. Делаем на основе 1С Розницы. По РМК - много чего там не доделано. Но самой большой проблемой оказалось не красота и разноцветность кнопок. Оказалось, что при открытии палитры быстрых товаров поле картинка заполняется динамически, при этом при смене страницы такая история повторяется каждый раз. Задержки получаются в 1-2 секунды. Это ну очень много. Даже на мощных компьютерах с процессорами в 3Ггц. В результате пришлось кэшировать формы, чтобы не переделывать много.
Так же стоит учесть, что магазины в которых достаточно большая проходимость используют сенсорные мониторы 4:3 размером 15 дюймов. Прикреплять основную панель выбора с боку это означает, что все сделать крайне мелко. За кнопку "сторно" зачет. Мы сделали так же назвали только "удалить товар". Ну и PS: если вы меняете оформление, не совсем понятно зачем делать внешнюю форму - делайте расширение :)

Видео о том как работает РМК у нас: https://www.youtube.com/watch?v=Bo6yW-h7icQ
Прикрепленные файлы:
asdfgcom; +1 Ответить
23. asdfgcom 230 09.11.18 16:08 Сейчас в теме
(22) Есть расширение и отдельно обработка. Не забывайте, что самой массовой является базовая версия продукта. Есть уже кое-какие доработки. В частности с ускорением работы. Доделывается вскрытие упаковки из РМК одной кнопкой (под разливнуху). После переделки под маркируемую продукцию (Табак) выложу обновление.
24. coolseo 47 14.11.18 02:31 Сейчас в теме
Еще бы увидеть такую фичу:
При подборе: чтобы выдавалась окно в котором можно ввести количество.
25. asdfgcom 230 14.11.18 07:20 Сейчас в теме
(24) Ага, как в УТ 10.3. Подумаю.
26. asdfgcom 230 17.11.18 11:37 Сейчас в теме
(24) Удалось реализовать подбор в боковой панеле (почти как в УТ 10.3).
Прикрепленные файлы:
coolseo; independ; +2 Ответить
27. coolseo 47 18.11.18 04:06 Сейчас в теме
(26)Спасибо. Тестирую.

1. При подключении расширения не правильно указан тип реквизита: должен быть строка 68
Расширение1: Значение контролируемого свойства Тип у объекта Обработка.РМКУправляемыйРежим.ТабличнаяЧасть.АкцизныеМарки.Реквизит.КодАкцизнойМарки не совпадает со значением в расширяемой конфигурации


2. При продаже через платежную карту
{АльтернативноеРМК Обработка.РМКУправляемыйРежимАльтернативный.Форма.ФормаРМК.Форма(10225)}: Ошибка при вызове метода контекста (Записать)
ОбъектЧекККМ.Записать(РежимЗаписиДокумента.Проведение, РежимПроведенияДокумента.Оперативный);
по причине:
Запись не верна! Значение поля "Документ расчета" не может быть пустым! (Регистр накопления: Расчеты с клиентами; Номер строки: 2)


3. При подборе из УТ 10.3 не хватает настройки формы - запрашивать количество при подборе.


4. Не понятно как сохранять настройки формы. Нет кнопки, не сохраняется контакты СЦ.

5. При нажатии кнопки поиск. Выходит ошибка

6. Пожелание: добавить в форму настройки - какую цену номенклатуры отображать в новом подборе. Очень удобно сразу видеть цену и ее называть покупателю, без добавления в список покупок.
Прикрепленные файлы:
28. dmitriy_zima 25.11.18 23:22 Сейчас в теме
а с отраслевыми не тестировалось?
29. asdfgcom 230 26.11.18 00:12 Сейчас в теме
(28) За небольшими изменениями должно работать на всех конфигурациях, являющихся модификацией Розницы
30. dmitriy_zima 26.11.18 01:03 Сейчас в теме
31. asdfgcom 230 26.11.18 09:33 Сейчас в теме
(30) К примеру Аптека, Рарус. Там доработан поиск по серийным номерам. Его надо перенести. Есть конфигурация с автозапчастями. Ее давно не видел. Короче, действовать надо по ситуации. Если у Вас есть опыт программирования, не сложно доработать под себя. Код ведь открыт.
32. dmitriy_zima 26.11.18 11:22 Сейчас в теме
(31) ок посмотрю что понадобится доработать. Кстати под тач есть предложение добавить кнопки навигации (вверх - вниз) по табличной части
33. asdfgcom 230 26.11.18 11:25 Сейчас в теме
(32) Верно! Вчера думал, как организовать передвижение по ТЧ чтобы поменять кол-во в строке или выполнить сторно. У меня мышка, мне просто, а кассир должен работать без мыши. С тачем или с клавиатуры, а после нажатия на любую кнопку теряется фокус на ТЧ. Сегодня же сделаю!
34. dmitriy_zima 26.11.18 12:58 Сейчас в теме
(33) обновления планируются или новую версию скачать снова только за мани?
35. asdfgcom 230 26.11.18 15:03 Сейчас в теме
(34) Конечно! Пока она за СМ обновления по просьбе в ЛС с ника, под которым производилось скачивание.
36. dmitriy_zima 26.11.18 15:47 Сейчас в теме
(35) ок. Если интересно, позже могу поделиться версией для аптеки. Планирую адаптировать если провизоров устроит интерфейс и как он будет выглядеть на 15 мониторах
37. coolseo 47 01.12.18 07:29 Сейчас в теме
(35)Здравствуйте, как - то продвигается работа над РМК? Я описал проблемы которые заметил. Готов тестировать ваше расширение. И прикладывать описание проблем и пожеланий.
38. asdfgcom 230 01.12.18 12:51 Сейчас в теме
(37)
1. При подключении расширения не правильно указан тип реквизита: должен быть строка 68

Обновиться до 2.2.9.20 или Выше.
2. При продаже через платежную карту...Запись не верна! Значение поля "Документ расчета" не может быть пустым!

Исправлено. Предыдущая версия имела ошибку при включенном режиме "Расчеты с клиентами" (Администрирование - Продажи)
3. При подборе из УТ 10.3 не хватает настройки формы - запрашивать количество при подборе.

На мой взгляд не нужно и нарушит основную концепцию идти по пути ускорения и защиты от сомнительных операций кассира. Как реализовано сейчас: После подбора в ТЧ нажать " * " - Количество - Enter. Что по количеству действий почти идентично и не вызывает перекрывающих форм.
4. Не понятно как сохранять настройки формы. Нет кнопки, не сохраняется контакты СЦ.

Настройки формы сохраняются в кэше 1С. Используется стандартный механизм "запоминания" настроек на управляемых формах. Настройки хранятся для каждого пользователя / для каждого рабочего места. Настройки потеряются при очистке кэша.
Контакты обслуживающей организации - в проекте. Не ясно, как их сохранять (буду использовать доп.свойства или доп.реквизиты ПВХ). Не ясно, отображать ли контакты постоянно или скрывать в закладку, чтобы контакт появлялся по требованию. Полагаю надо сделать закладку типа SOS, в которой будет телефон специалиста, и кнопки с привязкой к ПО для удаленного подключения. Буду проводить голосование, чтобы понять, кто, что использует. (teamviewer, ammiadmin, 1С-коннект... )
При нажатии кнопки поиск. Выходит ошибка

К кнопке поиск в тесте подключил команду на запуск внешней бесплатной клавиатуры: http://freevirtualkeyboard.com/
Кнопка Поиск не будет использоваться. Ее возможности полностью перекрывает Подбор. Если требуется развивать виртуальную клавиатуру - намекните.
Пожелание: добавить в форму настройки - какую цену номенклатуры отображать в новом подборе.

Реализовано. Отображается колонка с ценой, используемой при продаже. Поиск осуществляется по полям: Код/артикул/наименование/количество/цена. Возможна сортировка по алфавиту любых полей в подборе. Иерархический просмотр или списком.
Отображение количества и цены можно будет скрывать. Полезно для "Нагруженных" баз для ускорения работы подбора. Все мы понимаем, что если установлено динамическое считывание данных из регистра остатков и регистра свед. "Цены номенклатуры", динамический список подбора формируется каждый раз при открытии. Скорость открытия зависит от объема данных.

Новый релиз с большинством описанных доработок ожидается в понедельник.
Далее начнется работа по переносу механизма реализации маркируемой продукции в РМК.
39. dmitriy_zima 03.12.18 11:25 Сейчас в теме
(38) можно будет получить обновление на почту?
40. asdfgcom 230 03.12.18 11:45 Сейчас в теме
(39) Обязательно. Со сроками подвожу, правда.
41. VKuser30549868 5 07.12.18 12:24 Сейчас в теме
Здравствуйте. Есть возможность получить потестировать?
42. asdfgcom 230 07.12.18 15:48 Сейчас в теме
(41) Здравствуйте. По ссылке https://infostart.ru/public/922160/
Можно скачать версии для Проф, базовой или для обеих версий Розница 2.2
На этапе тестирования обработка распространяется за Sm. По окончании тестирования обработка получит защиту и будет распространяться за рубли.
Обработка уже эксплуатируется и имеет множество плюсов по отношению к прообразу, стандартному РМК Розницы, поэтому распространяется не бесплатно, к сожалению.
По результатам использования и пожеланиям к дальнейшему развитию проекта прошу написать здесь. Буду очень рад.
43. asdfgcom 230 09.12.18 18:49 Сейчас в теме
Обновление:
1. Добавлены кнопки вверх, вниз для "листания" таблицы чека.
2. Добавлена цена в подборе.
3. Переработано программное заполнение кнопок нижней панели. Теперь это не картинки, а кнопки. Можно задавать любые цвета и шрифты в настройке кнопок.
4. Добавлена возможность вызова экранной клавиатуры. Требуется настроить как на картинке. Клавиатура появляется при вызове подбора (если настроен вызов).
Следите за обновлением. Версия 1.2.5.
Прикрепленные файлы:
44. dmitriy_zima 10.12.18 17:44 Сейчас в теме
(43)уже скачавшим обновления будут или качать вновь за мани и не ждать?
45. asdfgcom 230 10.12.18 18:11 Сейчас в теме
(44) Конечно! Правда, это немного не та ветка. )))
46. asdfgcom 230 10.12.18 18:14 Сейчас в теме
(43) Клавиатура получилась не удобная. Она не закрывается сама. Ведет себя тупо. Не хотел, но придется писать программную клавиатуру.
Оставьте свое сообщение